Przejdź do głównej treści

Jak zmodyfikować lub zaktualizować wersję PHP WordPressa

Divi: najłatwiejszy w użyciu motyw WordPress

Divi: Najlepszy motyw WordPress wszechczasów!

więcej Pobieranie 901.000, Divi jest najpopularniejszym motywem WordPress na świecie. Jest kompletny, łatwy w użyciu i zawiera więcej niż darmowe szablony 62. [Zalecane]

Jeśli chcesz swojego bloga, swojej witryny lub swojego Sklep internetowy działa normalnie, najlepiej byłoby rozważyć zmianę lub aktualizację wersji PHP, której używasz w swojej witrynie. Nowa wersja PHP (PHP7) nie jest jeszcze wystarczająco rozpowszechniona, ale nie potrwa to długo, ponieważ przynosi wiele nowych funkcji i jest bardzo prawdopodobne, że będzie wymagana do instalacji lub używania kolejnych wersji WordPress. 

W tym artykule założono, że masz już witrynę lub blog WordPress. W przeciwnym razie zobacz ten szczegółowy przewodnik.

Ale jeśli już to zrobiłeś, kontynuujmy.  

Dlaczego warto uaktualnić do PHP 7?

Jeśli używasz WordPress na swoim serwerze, oczywiście masz już zainstalowany PHP. Po co więc aktualizować, kiedy wszystko wydaje się tak dobrze działać?

Oto niektóre z najczęstszych powodów, dla których warto rozważyć aktualizację swojej wersji PHP:

  • Wykonanie odcisków ucha jest konieczne, abyśmy mogli stworzyć Twoje monitory wtyczki i skrypty zainstalowane przez Ciebie oprogramowanie nie jest już zgodne z używaną wersją
  • Minimalne wymagania do uruchomienia WordPress wzrosły
  • Wersja, której używasz, ma wady bezpieczeństwa, a aktualizacja zawiera łatkę
  • Musisz migrować w kierunku bardziej stabilnej wersji
  • Chcesz przetestować inną wersję w instalacji WordPress lub w środowisku testowym
  • Znalazłeś konflikty między używaną wersją a zainstalowanymi wtyczkami, motywami lub skryptami

Czy kiedykolwiek myślałeś o ochronie swojego bloga lub witryny? tutaj jest Kilka porad, aby zabezpieczyć swój blog WordPress

To wszystko są ważne powody, ale zanim przejdziesz dalej i zaktualizujesz swoją wersję PHP, są pewne wady aktualizacji, które powinieneś rozważyć ...

Kilka ważnych wad, które należy wziąć pod uwagę ...

Przejście na nowszą wersję PHP wiąże się z pewnym ryzykiem. Oto dodatkowa wtyczka WordPress, która całkowicie wykona kopię zapasową witryny i przywróci ją w przypadku awarii.

Najważniejszą rzeczą, o której musisz pamiętać przed aktualizacją, jest to wszystkie twoje wtyczki, motywy i skrypty niekoniecznie są zgodne z najnowszą wersją PHP, której chcesz używać

W przypadku niekompatybilności jest bardzo prawdopodobne, że Twoja witryna nie nadaje się już do użytku lub zauważysz wiele błędów. Co więcej, WordPress powie Ci teraz, czy wtyczka jest kompatybilna z twoją wersją PHP, czy nie.

Jak zmienić aktualizację php wordpress

Każda wersja PHP oferuje nowe odmiany, ulepszenia i możliwe poprawki, poprawki bezpieczeństwa i strukturę kodu. Chociaż niektóre aktualizacje są mniej kompletne niż inne, wiele wersji oferuje ulepszenia lub zmiany, które powodują, że niektóre części starszych wersji stają się przestarzałe.

Łatwo stwórz swoją stronę internetową dzięki Elementor

Elementor pozwala łatwo stworzyć dowolny projekt strony internetowej o profesjonalnym wyglądzie. Przestań płacić drogo za to, co możesz zrobić sam. [Bezpłatny]

Odkryj też Niektóre wtyczki bezpieczeństwa WordPress dla Twojego bloga

W niektórych przypadkach całe wersje, takie jak PHP 4 i nowsze, nie są już obsługiwane. Jeśli używasz wtyczek, motywów lub skryptów w swojej witrynie, które zależą od przestarzałego kodu PHP i uaktualniasz do nowszej wersji PHP, to uaktualnienie sprawi, że kod stanie się przestarzały, a tym samym przerwie działanie. twojego bloga.

Chociaż tak nie jest pas zawsze tak jest, ważne jest, aby zdawać sobie sprawę, że zmiany, które wprowadzisz, będą miały konsekwencje. W ten sposób możesz rozważyć różne problemy ze zgodnością. Ale jeśli potrzebujesz motywu WordPress premium, który zawsze będzie aktualny, sprawdź następującą listę w zależności od Twojej niszy.

Oprócz ręcznego sprawdzania witryny internetowej pod kątem możliwych słabych punktów, istnieje wiele wtyczek, które poinformują Cię, czy Twoje środowisko można uaktualnić. Dobra wiadomość jest taka, że ​​możesz obniżyć wcześniej aktywowaną wersję. Innymi słowy, jeśli zauważysz jakieś błędy, zawsze można przywrócić poprzednią wersję PHP ... więc przełącz się na przykład z wersji 5.5 na wersję 7.xi jeśli wszystko nie działa dobrze, możesz wrócić do wersja 5.5

Sprawdź kompatybilność z PHP

Oto niektóre wtyczki, których możesz użyć do sprawdzenia kompatybilności swojego środowiska ze zaktualizowaną wersją PHP:

  • Sprawdzanie kompatybilności PHP  - Ta wtyczka umożliwia zdefiniowanie wersji PHP i analizę aktualnej wersji PHP Twojego hosta. Tworzy również raport, który informuje, co należy naprawić.
  • Dziennik błędów monitora   - Jeśli wystąpią jakieś błędy, możesz włączyć dziennik, aby śledzić wszystkie błędy, co pomoże Ci je łatwiej naprawić.

Możesz także aktywować ręcznie gazeta prywatnie błąd podczas używania „ WP_DEBUG ”. Możesz również zobaczyć, co się zmieniło dla każdej wersji PHP przed aktualizacją:

Jeśli okaże się, że używasz wtyczki, motywu lub skryptu, który nie jest zgodny z wersją PHP, której chcesz użyć, możesz skontaktować się z autorem lub programistą, aby uzyskać pomoc w rozwiązaniu problemu. Jeśli potrzebujesz pomocnej dłoni, możesz zostawić komentarz w tym artykule, chętnie udzielę odpowiedzi.

Jak zmienić wersję PHP

Tak więc, kiedy Twój blog przejdzie test zgodności, możesz zmienić wersję PHP, której używasz za pośrednictwem SSH lub cPanel. Jeśli nie jest to opcja, do której masz dostęp, skontaktuj się ze swoim host internetowy, W większości przypadków mogą dokonać aktualizacji lub wykonać inne zadania.

Szukasz najlepszych motywów i wtyczek WordPress?

Pobierz najlepsze wtyczki i motywy WordPress na Envato i łatwo stwórz swoją stronę. Już więcej niż pobrań 49.720.000. [EXCLUSIVE]

Aktualizacja przez SSH (zaawansowani użytkownicy)

Ponieważ polecenia SSH do aktualizacji lub instalacji innych wersji PHP różnią się w zależności od typu serwera, nie ma uniwersalnych poleceń, które działają wszędzie.

Chroń swojego bloga lub witrynę, korzystając z naszego samouczka: Sucuri: Skuteczne narzędzie do ochrony przed atakami na WordPress

Kliknij dowolny z poniższych zasobów, aby wyświetlić szczegóły w oparciu o typ serwera:

Pamiętaj, że jeśli używasz poleceń podanych w tych odsyłaczach, musisz także usunąć stary pakiet PHP z serwera. Ponieważ polecenia usuwania starszych wersji również będą się różnić w zależności od typu serwera, zapoznaj się z dokumentacją serwera, aby uzyskać dokładne polecenia.

Zaktualizuj lub zmień PHP w cPanel

Jeśli wolisz wybrać za pomocą kilku kliknięć wersję PHP dla twojego serwera, możesz to zrobić logując się na swoje konto cPanel. Jednak ta opcja jest dostępna tylko w domyślnych wersjach cPanel. Jeśli tak nie jest w Twoim przypadku, musisz skontaktować się w tym celu ze swoim dostawcą usług hostingowych.

Pokażę ci, jak uzyskać do niego dostęp z twojego cPanel. Po zalogowaniu przejdź do sekcji „Oprogramowanie”, a następnie kliknij „Menedżer MultiPHP”.

Oprogramowanie Cpanel

Kliknięcie go przeniesie Cię do zarządzania wersjami PHP dla różnych dostępnych domen i subdomen. Wystarczy, że wybierzesz odpowiednią wersję PHP i zastosujesz ją do wybranej domeny.

Wersja PHP cpanel domeny

Procedurę można wykonać w 3 prostych krokach, jak na poniższym obrazku:

Wybierz wersję php w domenie

Zauważysz, że interfejs będzie podobny do tego oferowanego przez WHM (jeśli masz serwer dedykowany).

Jak edytować z WHM

Jeśli masz serwer, prawdopodobnie masz instalację WHM, która pozwala zarządzać serwerem. Z WHM możesz także zmienić wersję domyślnie PHP na twoim cPanel. Wszystko, co musisz zrobić, to uzyskać dostęp do MultiPHP Manager i zmienić wersję PHP, której chcesz używać w każdej domenie.

Zmień wersję php whm

Z łatwością stwórz swój sklep internetowy

Uzyskaj woocommerce, najlepsze wtyczki e-commerce do sprzedaży produktów swoich fizycznych i cyfrowych na WordPressie. [Zalecane]

Kopia zapasowa wersji jest wykonywana automatycznie po zmianie wersji.

Polecane zasoby

Aby przejść dalej, zalecamy kilka artykułów, które pomogą ci zrozumieć, jak ważne jest posiadanie zaktualizowanej wersji php.

Wnioski

To wszystko, co możesz zrobić, aby zaktualizować swoją wersję PHP. Jeśli masz jakieś pytania, zostaw je w sekcji komentarzy. Możesz także odkryć dodatkowe zasoby, wchodząc na tę stronę.

Jeśli podoba Ci się ten artykuł, udostępnij go w różnych sieciach społecznościowych. 

Ten artykuł zawiera komentarze 9

  1. Witam,
    Nie mogę zaktualizować WordPressa, który wyświetla mi tę wiadomość
    Ważne: Przed aktualizacją utwórz kopię zapasową bazy danych i plików. Aby uzyskać pomoc dotyczącą aktualizacji, odwiedź stronę Aktualizowanie kodu WordPress.
    Napisałem do mojego hosta, który poprosił mnie o zaktualizowanie mojego php do wersji 7.3 i nadal mam tę blokującą wiadomość. Nie mam już dostępu do moich rozszerzeń.
    Czy jest coś jeszcze do zaktualizowania?
    Dziękuję bardzo za pomoc
    Bardzo dobry dzień

  2. Pozdrowienia Obecnie korzystam z szablonów stron internetowych. Mam 3 witryny, ale chcę zmienić jeden z moich szablonów witryn, ale skonfiguruję nowy szablon. Wersja 7 php będzie białym ekranem, jeśli wersja php została ustawiona na 5.9. Ale jeśli zmienię wersję php, moje inne witryny zostaną uszkodzone.

  3. Po utworzeniu bazy danych dla mojego projektu odświeżyłem się do pracy z wordpresse w wampie, oto wiadomość, którą otrzymałem.
    (Twój serwer używa wersji PHP 5.5.12, ale WordPress 5.2 wymaga co najmniej wersji 5.6.20)
    zaczynam i chciałbym zrozumieć, czy powinienem zaktualizować v wamp? czy wersję php, jeśli php jak kontynuować?

  4. Witam,

    Pozwalam sobie na przesłanie Ci tego e-maila, ponieważ jestem obecnie w trakcie kompletnego przerabiania strony jednego z moich klientów pod WordPress.
    Jednak niektóre wtyczki wymagają aktualizacji PHP. (Wymaga wersji 5.4 lub wyższej PHP, rozszerzenie jest obecnie nieaktywne.)
    Mój gospodarz nie odpowiada i jestem nowicjuszem komputerowym (zajmuję się Webdesignem)
    Czy możesz mi szczegółowo opisać procedurę aktualizacji PHP?
    Strona pochodzi z 2 lat.

    Z góry dziękuję za pomoc i poświęcony czas.

    Z poważaniem,

Zostaw komentarz

Twoj adres e-mail nie bedzie opublikowany. Wymagane pola są oznaczone *

Ta strona używa Akismet, aby zmniejszyć niechciane. Dowiedz się więcej o sposobie wykorzystania danych komentarzy.

Powrót do góry
3 akcji
udział1
ćwierkanie1
Enregistrer1